What’s Vulnerable › Vulnerabilities

CVE-2023-3907: Improper User Management in GitLab

Description

A privilege escalation vulnerability in GitLab EE affecting all versions from 16.0 prior to 16.4.4, 16.5 prior to 16.5.4, and 16.6 prior to 16.6.2 allows a project Maintainer to use a Project Access Token to escalate their role to Owner

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.4.4, 16.5.4, 16.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3907 or the next vulnerability affects your stack