What’s Vulnerable › Vulnerabilities
CVE-2023-3914: Incorrect User Management in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-29 · updated 2026-06-17
- Weakness: CWE-286
Description
A business logic error in GitLab EE affecting all versions prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1 allows access to internal projects. A service account is not deleted when a namespace is deleted, allowing access to internal projects.
Affected products
- GitLab: before 16.2.8; from 16.3.0 before 16.3.5; 16.4.0 — fixed in 16.2.8, 16.3.5
How to fix
Upgrade to a fixed version: GitLab 16.2.8, 16.3.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/418115
- https://hackerone.com/reports/2040822
- https://gitlab.com/gitlab-org/gitlab/-/issues/418115
- https://hackerone.com/reports/2040822
Get alerted when CVE-2023-3914 or the next vulnerability affects your stack