What’s Vulnerable › Vulnerabilities
CVE-2023-3915: Incorrect Execution-Assigned Permissions in GitLab
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-01 · updated 2026-06-17
- Weakness: CWE-279
Description
An issue has been discovered in GitLab EE affecting all versions starting from 16.1 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. If an external user is given an owner role on any group, that external user may escalate their privileges on the instance by creating a service account in that group. This service account is not classified as external and may be used to access internal projects.
Affected products
- GitLab: from 16.1.0 before 16.1.5; from 16.2 before 16.2.5; 16.3.0 — fixed in 16.1.5, 16.2.5
How to fix
Upgrade to a fixed version: GitLab 16.1.5, 16.2.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/417664
- https://hackerone.com/reports/2040834
- https://gitlab.com/gitlab-org/gitlab/-/issues/417664
- https://hackerone.com/reports/2040834
Get alerted when CVE-2023-3915 or the next vulnerability affects your stack