What’s Vulnerable › Vulnerabilities

CVE-2023-3917: Improper Validation of Specified Type of Input in GitLab

Description

Denial of Service in pipelines affecting all versions of Gitlab EE and CE prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1 allows attacker to cause pipelines to fail.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.2.8, 16.3.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3917 or the next vulnerability affects your stack