What’s Vulnerable › Vulnerabilities
CVE-2023-39176: Kernel: ksmbd: transform header out-of-bounds read information disclosure vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-10-08
- Weakness: CWE-125
Description
A flaw was found within the parsing of SMB2 requests that have a transform header in the kernel ksmbd module. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated buffer. An attacker can leverage this to disclose sensitive information on affected installations of Linux. Only systems with ksmbd enabled are vulnerable to this CVE.
Affected products
- Linux kernel: from 5.15.121 before 5.15.127; from 6.1.36 before 6.1.46; from 6.3 before 6.3.10; from 6.4 before 6.4.11 — fixed in 5.15.127, 6.1.46, 6.3.10, 6.4.11
How to fix
Upgrade to a fixed version: Linux kernel 5.15.127, 6.1.46, 6.3.10, 6.4.11. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-39176
- https://bugzilla.redhat.com/show_bug.cgi?id=2326503
- https://www.zerodayinitiative.com/advisories/ZDI-24-586/
Get alerted when CVE-2023-39176 or the next vulnerability affects your stack