What’s Vulnerable › Vulnerabilities
CVE-2023-39251
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-20
Description
Dell BIOS contains an Improper Input Validation vulnerability. A local malicious user with high privileges could potentially exploit this vulnerability in order to corrupt memory on the system.
Affected products
- Dell Inspiron 7510 Firmware: before 1.20.0 — fixed in 1.20.0
- Dell Inspiron 7610 Firmware: before 1.20.0 — fixed in 1.20.0
- Dell Latitude 5430 Rugged Firmware: before 1.23.0 — fixed in 1.23.0
- Dell Latitude 5521 Firmware: before 1.27.0 — fixed in 1.27.0
- Dell Latitude 7330 Rugged Firmware: before 1.23.0 — fixed in 1.23.0
- Dell Precision 3561 Firmware: before 1.27.0 — fixed in 1.27.0
- Dell Precision 5560 Firmware: before 1.25.0 — fixed in 1.25.0
- Dell Precision 5760 Firmware: before 1.24.0 — fixed in 1.24.0
- Dell Precision 7560 Firmware: before 1.27.0 — fixed in 1.27.0
- Dell Precision 7760 Firmware: before 1.27.0 — fixed in 1.27.0
- Dell Vostro 7510 Firmware: before 1.20.0 — fixed in 1.20.0
- Dell Xps 15 9510 Firmware: before 1.25.0 — fixed in 1.25.0
- Dell Xps 17 9710 Firmware: before 1.24.0 — fixed in 1.24.0
How to fix
Upgrade to a fixed version: Dell Inspiron 7510 Firmware 1.20.0; Dell Inspiron 7610 Firmware 1.20.0; Dell Latitude 5430 Rugged Firmware 1.23.0; Dell Latitude 5521 Firmware 1.27.0; Dell Latitude 7330 Rugged Firmware 1.23.0; Dell Precision 3561 Firmware 1.27.0; Dell Precision 5560 Firmware 1.25.0; Dell Precision 5760 Firmware 1.24.0; Dell Precision 7560 Firmware 1.27.0; Dell Precision 7760 Firmware 1.27.0; Dell Vostro 7510 Firmware 1.20.0; Dell Xps 15 9510 Firmware 1.25.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000217707/dsa-2023-342
- https://www.dell.com/support/kbdoc/en-us/000217707/dsa-2023-342
Get alerted when CVE-2023-39251 or the next vulnerability affects your stack