What’s Vulnerable › Vulnerabilities
CVE-2023-39254
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-427
Description
Dell Update Package (DUP), Versions prior to 4.9.10 contain an Uncontrolled Search Path vulnerability. A malicious user with local access to the system could potentially exploit this vulnerability to run arbitrary code as admin.
Affected products
- Dell Update Package Framework: before 4.9.10 — fixed in 4.9.10
How to fix
Upgrade to a fixed version: Dell Update Package Framework 4.9.10. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000217701/dsa-2023-338-security-update-for-a-dell-update-package-dup-framework-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000217701/dsa-2023-338-security-update-for-a-dell-update-package-dup-framework-vulnerability
Get alerted when CVE-2023-39254 or the next vulnerability affects your stack