What’s Vulnerable › Vulnerabilities
CVE-2023-39268: Memory Corruption Vulnerability in ArubaOS-Switch
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-29 · updated 2026-06-17
- Weakness: CWE-787
Description
A memory corruption vulnerability in ArubaOS-Switch could lead to unauthenticated remote code execution by receiving specially crafted packets. Successful exploitation of this vulnerability results in the ability to execute arbitrary code as a privileged user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise ArubaOS-Switch: before a.15.16.0026; from 16.01.0000 before 16.04.0027; from 16.05.0000 before 16.08.0027; from 16.10.0001 before 16.10.0024; from 16.11.0001 before 16.11.0013 — fixed in 16.04.0027, 16.08.0027, 16.10.0024, 16.11.0013, a.15.16.0026
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise ArubaOS-Switch 16.04.0027, 16.08.0027, 16.10.0024, 16.11.0013. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-013.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-013.txt
Get alerted when CVE-2023-39268 or the next vulnerability affects your stack