What’s Vulnerable › Vulnerabilities

CVE-2023-3932: Incorrect User Management in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. It was possible for an attacker to run pipeline jobs as an arbitrary user via scheduled security scan policies.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.0.8, 16.1.3, 16.2.2; GitLab 16.0.8, 16.1.3, 16.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3932 or the next vulnerability affects your stack