What’s Vulnerable › Vulnerabilities
CVE-2023-39320: Arbitrary code execution via go.mod toolchain directive in cmd/go
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-08 · updated 2026-06-17
- Weakness: CWE-94
Description
The go.mod toolchain directive, introduced in Go 1.21, can be leveraged to execute scripts and binaries relative to the root of the module when the "go" command was executed within the module. This applies to modules downloaded using the "go" command from the module proxy, as well as modules downloaded directly using VCS software.
Affected products
- Go: from 1.21.0 before 1.21.1 — fixed in 1.21.1
How to fix
Upgrade to a fixed version: Go 1.21.1. Check the vendor advisory for mitigations.
References
- https://go.dev/cl/526158
- https://go.dev/issue/62198
- https://groups.google.com/g/golang-dev/c/2C5vbR-UNkI/m/L1hdrPhfBAAJ
- https://pkg.go.dev/vuln/GO-2023-2042
- https://security.gentoo.org/glsa/202311-09
- https://security.netapp.com/advisory/ntap-20231020-0004/
- https://go.dev/cl/526158
- https://go.dev/issue/62198
- https://groups.google.com/g/golang-dev/c/2C5vbR-UNkI/m/L1hdrPhfBAAJ
- https://pkg.go.dev/vuln/GO-2023-2042
- https://security.gentoo.org/glsa/202311-09
- https://security.netapp.com/advisory/ntap-20231020-0004/
Get alerted when CVE-2023-39320 or the next vulnerability affects your stack