What’s Vulnerable › Vulnerabilities
CVE-2023-39331
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-18 · updated 2026-06-17
- Weakness: CWE-22
Description
A previously disclosed vulnerability (CVE-2023-30584) was patched insufficiently in commit 205f1e6. The new path traversal vulnerability arises because the implementation does not protect itself against the application overwriting built-in utility functions with user-defined implementations. Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.
Affected products
- Node.js: from 20.0.0 before 20.8.1 — fixed in 20.8.1
How to fix
Upgrade to a fixed version: Node.js 20.8.1. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/2092852
- https://security.netapp.com/advisory/ntap-20231116-0009/
- https://hackerone.com/reports/2092852
- https://security.netapp.com/advisory/ntap-20231116-0009/
- https://security.netapp.com/advisory/ntap-20241108-0002/
Get alerted when CVE-2023-39331 or the next vulnerability affects your stack