What’s Vulnerable › Vulnerabilities
CVE-2023-39333
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-07 · updated 2026-06-17
- Weakness: CWE-94
Description
Maliciously crafted export names in an imported WebAssembly module can inject JavaScript code. The injected code may be able to access data and functions that the WebAssembly module itself does not have access to, similar to as if the WebAssembly module was a JavaScript module. This vulnerability affects users of any active release line of Node.js. The vulnerable feature is only available if Node.js is started with the `--experimental-wasm-modules` command line option.
Affected products
- nodejs: from 18.0 before 18.18.2; from 20.0 before 20.8.1 — fixed in 18.18.2, 20.8.1
How to fix
Upgrade to a fixed version: nodejs 18.18.2, 20.8.1. Check the vendor advisory for mitigations.
References
- https://nodejs.org/en/blog/vulnerability/october-2023-security-releases
- https://security.netapp.com/advisory/ntap-20240808-0004/
- https://security.netapp.com/advisory/ntap-20241004-0006/
- https://security.netapp.com/advisory/ntap-20241108-0002/
Get alerted when CVE-2023-39333 or the next vulnerability affects your stack