What’s Vulnerable › Vulnerabilities
CVE-2023-39342: Dangerzone CLI does not sanitize ANSI escape characters
- Severity: low (CVSS 3.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-08 · updated 2026-06-17
- Weakness: CWE-150
Description
Dangerzone is software for converting potentially dangerous PDFs, office documents, or images to safe PDFs. The Dangerzone CLI (`dangerzone-cli` command) logs output from the container where the file sanitization takes place, to the user's terminal. Prior to version 0.4.2, if the container is compromised and can return attacker-controlled strings, then the attacker may be able to spoof messages in the user's terminal or change the window title. Besides logging output from containers, it also logs the names of the files it sanitizes. If these files contain ANSI escape sequences, then the same issue applies. Dangerzone is predominantly a GUI application, so this issue should leave most of our users unaffected. Nevertheless, we always suggest updating to the newest version. This issue is fixed in Dangerzone 0.4.2.
Affected products
- freedomofpress dangerzone: before 0.4.2 — fixed in 0.4.2
How to fix
Upgrade to a fixed version: freedomofpress dangerzone 0.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/freedomofpress/dangerzone/pull/491
- https://github.com/freedomofpress/dangerzone/releases/tag/v0.4.2
- https://github.com/freedomofpress/dangerzone/security/advisories/GHSA-pvwq-6vpp-2632
- https://github.com/freedomofpress/dangerzone/pull/491
- https://github.com/freedomofpress/dangerzone/releases/tag/v0.4.2
- https://github.com/freedomofpress/dangerzone/security/advisories/GHSA-pvwq-6vpp-2632
Get alerted when CVE-2023-39342 or the next vulnerability affects your stack