What’s Vulnerable › Vulnerabilities
CVE-2023-39347: Cilium NetworkPolicy bypass via pod labels
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-345
Description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. An attacker with the ability to update pod labels can cause Cilium to apply incorrect network policies. This issue arises due to the fact that on pod update, Cilium incorrectly uses user-provided pod labels to select the policies which apply to the workload in question. This can affect Cilium network policies that use the namespace, service account or cluster constructs to restrict traffic, Cilium clusterwide network policies that use Cilium namespace labels to select the Pod and Kubernetes network policies. Non-existent construct names can be provided, which bypass all network policies applicable to the construct. For example, providing a pod with a non-existent namespace as the value of the `io.kubernetes.pod.namespace` label results in none of the namespaced CiliumNetworkPolicies applying to the pod in question. This attack requires the attacker to have Kubernetes API Server access, as described in the Cilium Threat Model. This issue has been resolved in: Cilium versions 1.14.2, 1.13.7, and 1.12.14. Users are advised to upgrade. As a workaround an admission webhook can be used to prevent pod label updates to the `k8s:io.kubernetes.pod.namespace` and `io.cilium.k8s.policy.*` keys.
Affected products
- cilium: before 1.12.14; from 1.13.0 before 1.13.7; from 1.14.0 before 1.14.2 — fixed in 1.12.14, 1.13.7, 1.14.2
How to fix
Upgrade to a fixed version: cilium 1.12.14, 1.13.7, 1.14.2. Check the vendor advisory for mitigations.
References
- https://docs.cilium.io/en/latest/security/threat-model/#kubernetes-api-server-attacker
- https://github.com/cilium/cilium/security/advisories/GHSA-gj2r-phwg-6rww
- https://docs.cilium.io/en/latest/security/threat-model/#kubernetes-api-server-attacker
- https://github.com/cilium/cilium/security/advisories/GHSA-gj2r-phwg-6rww
Get alerted when CVE-2023-39347 or the next vulnerability affects your stack