What’s Vulnerable › Vulnerabilities
CVE-2023-39349: Sentry vulnerable to privilege escalation via ApiTokensEndpoint
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-07 · updated 2026-06-17
- Weakness: CWE-284
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 22.1.0 and prior to version 23.7.2, an attacker with access to a token with few or no scopes can query `/api/0/api-tokens/` for a list of all tokens created by a user, including tokens with greater scopes, and use those tokens in other requests. There is no evidence that the issue was exploited on `sentry.io`. For self-hosted users, it is advised to rotate user auth tokens. A fix is available in version 23.7.2 of `sentry` and `self-hosted`. There are no known workarounds.
Affected products
- getsentry sentry: from 22.1.0 before 23.7.2 — fixed in 23.7.2
How to fix
Upgrade to a fixed version: getsentry sentry 23.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/self-hosted/releases/tag/23.7.2
- https://github.com/getsentry/sentry/commit/fad12c1150d1135edf9666ea72ca11bc110c1083
- https://github.com/getsentry/sentry/pull/53850
- https://github.com/getsentry/sentry/releases/tag/23.7.2
- https://github.com/getsentry/sentry/security/advisories/GHSA-9jcq-jf57-c62c
- https://github.com/getsentry/self-hosted/releases/tag/23.7.2
- https://github.com/getsentry/sentry/commit/fad12c1150d1135edf9666ea72ca11bc110c1083
- https://github.com/getsentry/sentry/pull/53850
- https://github.com/getsentry/sentry/releases/tag/23.7.2
- https://github.com/getsentry/sentry/security/advisories/GHSA-9jcq-jf57-c62c
Get alerted when CVE-2023-39349 or the next vulnerability affects your stack