What’s Vulnerable › Vulnerabilities
CVE-2023-3936: Blog2Social < 7.2.1 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-21 · updated 2026-06-17
Description
The Blog2Social WordPress plugin before 7.2.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- pr-gateway Blog2Social: Social Media Auto Post & Scheduler: before 7.2.1 — fixed in 7.2.1
How to fix
Upgrade to a fixed version: pr-gateway Blog2Social: Social Media Auto Post & Scheduler 7.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6d09a5d3-046d-47ef-86b4-c024ea09dc0f
- https://wpscan.com/vulnerability/6d09a5d3-046d-47ef-86b4-c024ea09dc0f
Get alerted when CVE-2023-3936 or the next vulnerability affects your stack