What’s Vulnerable › Vulnerabilities
CVE-2023-39410: Apache Avro Java SDK: Memory when deserializing untrusted data in Avro Java SDK
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-29 · updated 2026-06-17
- Weakness: CWE-502
Description
When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.
Affected products
- Apache Software Foundation Apache Avro: before 1.11.3 — fixed in 1.11.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Avro 1.11.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/q142wj99cwdd0jo5lvdoxzoymlqyjdds
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://www.openwall.com/lists/oss-security/2023/09/29/6
- https://lists.apache.org/thread/q142wj99cwdd0jo5lvdoxzoymlqyjdds
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://www.openwall.com/lists/oss-security/2023/09/29/6
Get alerted when CVE-2023-39410 or the next vulnerability affects your stack