What’s Vulnerable › Vulnerabilities
CVE-2023-39441: Apache Airflow SMTP Provider, Apache Airflow IMAP Provider, Apache Airflow: SMTP/IMAP client components allowed MITM due to missing Certificate Validation
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-23 · updated 2026-06-17
- Weakness: CWE-295
Description
Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate. Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability
Affected products
- Apache Airflow: before 2.7.0 — fixed in 2.7.0
- Apache-Airflow-Providers-Imap: before 3.3.0 — fixed in 3.3.0
- Apache-Airflow-Providers-Smtp: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.7.0; Apache-Airflow-Providers-Imap 3.3.0; Apache-Airflow-Providers-Smtp 1.3.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/08/23/2
- https://github.com/apache/airflow/pull/33070
- https://github.com/apache/airflow/pull/33075
- https://github.com/apache/airflow/pull/33108
- https://lists.apache.org/thread/xzp4wgjg2b1o6ylk2595df8bstlbo1lb
- http://www.openwall.com/lists/oss-security/2023/08/23/2
- https://github.com/apache/airflow/pull/33070
- https://github.com/apache/airflow/pull/33075
- https://github.com/apache/airflow/pull/33108
- https://lists.apache.org/thread/xzp4wgjg2b1o6ylk2595df8bstlbo1lb
Get alerted when CVE-2023-39441 or the next vulnerability affects your stack