What’s Vulnerable › Vulnerabilities
CVE-2023-39470: PaperCut NG print.script.sandboxed Exposed Dangerous Function Remote Code Execution Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-749
Description
PaperCut NG print.script.sandboxed Exposed Dangerous Function Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of PaperCut NG. Authentication is required to exploit this vulnerability. The specific flaw exists within the management of the print.script.sandboxed setting. The issue results from the exposure of a dangerous function. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. Was ZDI-CAN-20965.
Affected products
- PaperCut NG: before 22.1.1 — fixed in 22.1.1
How to fix
Upgrade to a fixed version: PaperCut NG 22.1.1. Check the vendor advisory for mitigations.
References
- https://www.papercut.com/kb/Main/SecurityBulletinJune2023/
- https://www.zerodayinitiative.com/advisories/ZDI-24-786/
Get alerted when CVE-2023-39470 or the next vulnerability affects your stack