What’s Vulnerable › Vulnerabilities
CVE-2023-39481: Softing Secure Integration Server Interpretation Conflict Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-436
Description
Softing Secure Integration Server Interpretation Conflict Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Softing Secure Integration Server. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed. The specific flaw exists within the web server. The issue results from an inconsistency in URI parsing between NGINX and application code. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of root. Was ZDI-CAN-20551.
Affected products
- Softing Secure Integration Server: before 1.30 — fixed in 1.30
How to fix
Upgrade to a fixed version: Softing Secure Integration Server 1.30. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-23-1063/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1063/
Get alerted when CVE-2023-39481 or the next vulnerability affects your stack