What’s Vulnerable › Vulnerabilities
CVE-2023-39517: Cross site scripting (XSS) when clicking on an untrusted `<map>` link in Joplin
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Joplin is a free, open source note taking and to-do application. A Cross site scripting (XSS) vulnerability in affected versions allows clicking on an untrusted image link to execute arbitrary shell commands. The HTML sanitizer (`packages/renderer/htmlUtils.ts::sanitizeHtml`) preserves `<map>` `<area>` links. However, unlike `<a>` links, the `target` and `href` attributes are not removed. Additionally, because the note preview pane isn't sandboxed to prevent top navigation, links with `target` set to `_top` can replace the toplevel electron page. Because any toplevel electron page, with Joplin's setup, has access to `require` and can require node libraries, a malicious replacement toplevel page can import `child_process` and execute arbitrary shell commands. This issue has been fixed in commit 7c52c3e9a81a52ef1b42a951f9deb9d378d59b0f which is included in release version 2.12.8. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- laurent22 joplin: before 2.12.8 — fixed in 2.12.8
How to fix
Upgrade to a fixed version: laurent22 joplin 2.12.8. Check the vendor advisory for mitigations.
References
- https://developer.mozilla.org/en-US/docs/Web/HTML/Element/iframe#sandbox
- https://github.com/laurent22/joplin/commit/7c52c3e9a81a52ef1b42a951f9deb9d378d59b0f
- https://github.com/laurent22/joplin/security/advisories/GHSA-2h88-m32f-qh5m
- https://developer.mozilla.org/en-US/docs/Web/HTML/Element/iframe#sandbox
- https://github.com/laurent22/joplin/commit/7c52c3e9a81a52ef1b42a951f9deb9d378d59b0f
- https://github.com/laurent22/joplin/security/advisories/GHSA-2h88-m32f-qh5m
Get alerted when CVE-2023-39517 or the next vulnerability affects your stack