What’s Vulnerable › Vulnerabilities
CVE-2023-39520: Cryptomator vulnerable to Local Elevation of Privileges
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-07 · updated 2026-06-17
- Weakness: CWE-269
Description
Cryptomator encrypts data being stored on cloud infrastructure. The MSI installer provided on the homepage for Cryptomator version 1.9.2 allows local privilege escalation for low privileged users, via the `repair` function. The problem occurs as the repair function of the MSI is spawning an SYSTEM Powershell without the `-NoProfile` parameter. Therefore the profile of the user starting the repair will be loaded. Version 1.9.3 contains a fix for this issue. Adding a `-NoProfile` to the powershell is a possible workaround.
Affected products
- cryptomator: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: cryptomator 1.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/cryptomator/cryptomator/commit/727c32ad50c3901a6144a11cf984a3b7ebcf8b2b
- https://github.com/cryptomator/cryptomator/releases/download/1.9.2/Cryptomator-1.9.2-x64.msi
- https://github.com/cryptomator/cryptomator/releases/tag/1.9.3
- https://github.com/cryptomator/cryptomator/security/advisories/GHSA-62gx-54j7-mjh3
- https://github.com/cryptomator/cryptomator/commit/727c32ad50c3901a6144a11cf984a3b7ebcf8b2b
- https://github.com/cryptomator/cryptomator/releases/download/1.9.2/Cryptomator-1.9.2-x64.msi
- https://github.com/cryptomator/cryptomator/releases/tag/1.9.3
- https://github.com/cryptomator/cryptomator/security/advisories/GHSA-62gx-54j7-mjh3
Get alerted when CVE-2023-39520 or the next vulnerability affects your stack