What’s Vulnerable › Vulnerabilities
CVE-2023-39524: PrestaShop vulnerable to boolean SQL injection in search product in BO
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-07 · updated 2026-06-17
- Weakness: CWE-89
Description
PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, SQL injection possible in the product search field, in BO's product page. Version 8.1.1 contains a patch for this issue. There are no known workarounds.
Affected products
- PrestaShop: before 8.1.1 — fixed in 8.1.1
How to fix
Upgrade to a fixed version: PrestaShop 8.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/2047d4c053043102bc46a37d383b392704bf14d7
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-75p5-jwx4-qw9h
- https://github.com/PrestaShop/PrestaShop/commit/2047d4c053043102bc46a37d383b392704bf14d7
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-75p5-jwx4-qw9h
Get alerted when CVE-2023-39524 or the next vulnerability affects your stack