What’s Vulnerable › Vulnerabilities
CVE-2023-39525: PrestaShop vulnerable to path traversal
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-07 · updated 2026-06-17
- Weakness: CWE-22
Description
PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, in the back office, files can be compromised using path traversal by replaying the import file deletion query with a specified file path that uses the traversal path. Version 8.1.1 contains a patch for this issue. There are no known workarounds.
Affected products
- PrestaShop: before 8.1.1 — fixed in 8.1.1
How to fix
Upgrade to a fixed version: PrestaShop 8.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/c7c9a5110421bb2856f4d312ecce192d079b5ec7
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-m9r4-3fg7-pqm2
- https://github.com/PrestaShop/PrestaShop/commit/c7c9a5110421bb2856f4d312ecce192d079b5ec7
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-m9r4-3fg7-pqm2
Get alerted when CVE-2023-39525 or the next vulnerability affects your stack