What’s Vulnerable › Vulnerabilities

CVE-2023-39527: PrestaShop XSS vulnerability through Validate::isCleanHTML method

Description

PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to cross-site scripting through the `isCleanHTML` method. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.

Affected products

How to fix

Upgrade to a fixed version: PrestaShop 1.7.8.10, 8.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-39527 or the next vulnerability affects your stack