What’s Vulnerable › Vulnerabilities
CVE-2023-39529: PrestaShop vulnerable to file deletion via attachment API
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-07 · updated 2026-06-17
- Weakness: CWE-20
Description
PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, it is possible to delete a file from the server by using the Attachments controller and the Attachments API. Version 8.1.1 contains a patch for this issue. There are no known workarounds.
Affected products
- PrestaShop: before 8.1.1 — fixed in 8.1.1
How to fix
Upgrade to a fixed version: PrestaShop 8.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/b08c647305dc1e9e6a2445b724d13a9733b6ed82
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-2rf5-3fw8-qm47
- https://github.com/PrestaShop/PrestaShop/commit/b08c647305dc1e9e6a2445b724d13a9733b6ed82
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-2rf5-3fw8-qm47
Get alerted when CVE-2023-39529 or the next vulnerability affects your stack