What’s Vulnerable › Vulnerabilities
CVE-2023-39530: PrestaShop vulnerable to file deletion via CustomerMessage
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-07 · updated 2026-06-17
- Weakness: CWE-20
Description
PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, it is possible to delete files from the server via the CustomerMessage API. Version 8.1.1 contains a patch for this issue. There are no known workarounds.
Affected products
- PrestaShop: before 8.1.1 — fixed in 8.1.1
How to fix
Upgrade to a fixed version: PrestaShop 8.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/6ce750b2367a7309b6bf50166f1873cb86ad57e9
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-v4gr-v679-42p7
- https://github.com/PrestaShop/PrestaShop/commit/6ce750b2367a7309b6bf50166f1873cb86ad57e9
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-v4gr-v679-42p7
Get alerted when CVE-2023-39530 or the next vulnerability affects your stack