What’s Vulnerable › Vulnerabilities
CVE-2023-39531: Sentry vulnerable to incorrect credential validation on OAuth token requests
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-09 · updated 2026-06-17
- Weakness: CWE-287
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
Affected products
- getsentry sentry: from 10.0.0 before 23.7.2 — fixed in 23.7.2
How to fix
Upgrade to a fixed version: getsentry sentry 23.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/sentry/security/advisories/GHSA-hgj4-h2x3-rfx4
- https://github.com/getsentry/sentry/security/advisories/GHSA-hgj4-h2x3-rfx4
Get alerted when CVE-2023-39531 or the next vulnerability affects your stack