What’s Vulnerable › Vulnerabilities
CVE-2023-39534: Malformed GAP submessage triggers assertion failure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-11 · updated 2026-06-17
- Weakness: CWE-617
Description
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.10.0, 2.9.2, and 2.6.5, a malformed GAP submessage can trigger assertion failure, crashing FastDDS. Version 2.10.0, 2.9.2, and 2.6.5 contain a patch for this issue.
Affected products
- Debian Linux: 11.0, 12.0
- eProsima Fast-DDS: from 2.6.0 before 2.6.5; from 2.9.0 before 2.9.2; 2.10.0-rc1 — fixed in 2.6.5, 2.9.2
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.6.5, 2.9.2. Check the vendor advisory for mitigations.
References
- https://bombshell.gtisc.gatech.edu/ddsfuzz/pcap/fastdds-assert-230509.pcap
- https://github.com/eProsima/Fast-DDS/blob/v2.9.1/include/fastdds/rtps/common/SequenceNumber.h#L238-L252
- https://github.com/eProsima/Fast-DDS/blob/v2.9.1/src/cpp/rtps/reader/StatefulReader.cpp#L863
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-fcr6-x23w-94wp
- https://www.debian.org/security/2023/dsa-5481
- https://bombshell.gtisc.gatech.edu/ddsfuzz/pcap/fastdds-assert-230509.pcap
- https://github.com/eProsima/Fast-DDS/blob/v2.9.1/include/fastdds/rtps/common/SequenceNumber.h#L238-L252
- https://github.com/eProsima/Fast-DDS/blob/v2.9.1/src/cpp/rtps/reader/StatefulReader.cpp#L863
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-fcr6-x23w-94wp
- https://www.debian.org/security/2023/dsa-5481
Get alerted when CVE-2023-39534 or the next vulnerability affects your stack