What’s Vulnerable › Vulnerabilities
CVE-2023-39553: Apache Airflow Drill Provider Arbitrary File Read Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-11 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider. Apache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server. This issue affects Apache Airflow Drill Provider: before 2.4.3. It is recommended to upgrade to a version that is not affected.
Affected products
- Apache Software Foundation Apache Airflow Drill Provider: before 2.4.3 — fixed in 2.4.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Drill Provider 2.4.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/08/11/1
- https://github.com/apache/airflow/pull/33074
- https://lists.apache.org/thread/ozpl0opmob49rkcz8svo8wkxyw1395sf
- http://www.openwall.com/lists/oss-security/2023/08/11/1
- https://github.com/apache/airflow/pull/33074
- https://lists.apache.org/thread/ozpl0opmob49rkcz8svo8wkxyw1395sf
Get alerted when CVE-2023-39553 or the next vulnerability affects your stack