What’s Vulnerable › Vulnerabilities
CVE-2023-3958: WP Remote Users Sync <= 1.2.12 - Authenticated (Subscriber+) Server Side Request Forgery
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-918
Description
The WP Remote Users Sync plugin for WordPress is vulnerable to Server Side Request Forgery via the 'notify_ping_remote' AJAX function in versions up to, and including, 1.2.12. This can allow authenticated attackers with subscriber-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. This was partially patched in version 1.2.12 and fully patched in version 1.2.13.
Affected products
- frogerme WP Remote Users Sync: before 1.2.13 — fixed in 1.2.13
How to fix
Upgrade to a fixed version: frogerme WP Remote Users Sync 1.2.13. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-remote-users-sync/trunk/inc/api/class-wprus-api-abstract.php#L674
- https://plugins.trac.wordpress.org/changeset/2946667/wp-remote-users-sync#file127
- https://plugins.trac.wordpress.org/changeset/2953845/wp-remote-users-sync#file0
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2e78c759-4a54-4ee4-8eff-df91fe9dad46?source=cve
- https://plugins.trac.wordpress.org/browser/wp-remote-users-sync/trunk/inc/api/class-wprus-api-abstract.php#L674
- https://plugins.trac.wordpress.org/changeset/2946667/wp-remote-users-sync#file127
- https://plugins.trac.wordpress.org/changeset/2953845/wp-remote-users-sync#file0
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2e78c759-4a54-4ee4-8eff-df91fe9dad46?source=cve
Get alerted when CVE-2023-3958 or the next vulnerability affects your stack