What’s Vulnerable › Vulnerabilities
CVE-2023-3966: Openvswsitch: ovs-vswitch fails to recover after malformed geneve metadata packet
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-22 · updated 2026-06-17
- Weakness: CWE-248
Description
A flaw was found in Open vSwitch where multiple versions are vulnerable to crafted Geneve packets, which may result in a denial of service and invalid memory accesses. Triggering this issue requires that hardware offloading via the netlink path is enabled.
Affected products
- Fedoraproject Fedora: 39, 40
- Openvswitch: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Openvswitch 3.1.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-3966
- https://bugzilla.redhat.com/show_bug.cgi?id=2178363
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LFZADABUDOFI2KZIRQBYFZCIKH55RGY3/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VYYUBF6OW2JG7VOFEOROHXGSJCTES3QO/
- https://access.redhat.com/security/cve/CVE-2023-3966
- https://bugzilla.redhat.com/show_bug.cgi?id=2178363
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LFZADABUDOFI2KZIRQBYFZCIKH55RGY3/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VYYUBF6OW2JG7VOFEOROHXGSJCTES3QO/
Get alerted when CVE-2023-3966 or the next vulnerability affects your stack