What’s Vulnerable › Vulnerabilities

CVE-2023-3979: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab affecting all versions starting from 10.6 before 16.2.8, all versions starting from 16.3 before 16.3.5, all versions starting from 16.4 before 16.4.1. It was possible that upstream members to collaborate with you on your branch get permission to write to the merge request’s source branch.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.2.8, 16.3.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3979 or the next vulnerability affects your stack