What’s Vulnerable › Vulnerabilities
CVE-2023-39804
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
Description
In GNU tar before 1.35, mishandled extension attributes in a PAX archive can lead to an application crash in xheader.c.
Affected products
- GNU Tar: before 1.35 — fixed in 1.35
How to fix
Upgrade to a fixed version: GNU Tar 1.35. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1058079
- https://git.savannah.gnu.org/cgit/tar.git/commit/?id=a339f05cd269013fa133d2f148d73f6f7d4247e4
- https://git.savannah.gnu.org/cgit/tar.git/tree/src/xheader.c?h=release_1_34#n1723
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1058079
- https://git.savannah.gnu.org/cgit/tar.git/commit/?id=a339f05cd269013fa133d2f148d73f6f7d4247e4
- https://git.savannah.gnu.org/cgit/tar.git/tree/src/xheader.c?h=release_1_34#n1723
- https://lists.debian.org/debian-lts-announce/2024/03/msg00008.html
Get alerted when CVE-2023-39804 or the next vulnerability affects your stack