What’s Vulnerable › Vulnerabilities
CVE-2023-39908
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-125
Description
The PKCS11 module of the YubiHSM 2 SDK through 2023.01 does not properly validate the length of specific read operations on object metadata. This may lead to disclosure of uninitialized and previously used memory.
Affected products
- Yubico Yubihsm 2 Sdk: before 2023.08 — fixed in 2023.08
How to fix
Upgrade to a fixed version: Yubico Yubihsm 2 Sdk 2023.08. Check the vendor advisory for mitigations.
References
- https://blog.inhq.net/posts/yubico-yubihsm-pkcs-vuln/
- https://www.yubico.com/support/security-advisories/ysa-2023-01/
- https://blog.inhq.net/posts/yubico-yubihsm-pkcs-vuln/
- https://www.yubico.com/support/security-advisories/ysa-2023-01/
Get alerted when CVE-2023-39908 or the next vulnerability affects your stack