What’s Vulnerable › Vulnerabilities
CVE-2023-39914: BER/CER/DER decoder panics on invalid input
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-13 · updated 2026-06-17
- Weakness: CWE-232
Description
NLnet Labs' bcder library up to and including version 0.7.2 panics while decoding certain invalid input data rather than rejecting the data with an error. This can affect both the actual decoding stage as well as accessing content of types that utilized delayed decoding.
Affected products
- NLnet Labs bcder: before 0.7.3 — fixed in 0.7.3
How to fix
Upgrade to a fixed version: NLnet Labs bcder 0.7.3. Check the vendor advisory for mitigations.
References
- https://nlnetlabs.nl/downloads/bcder/CVE-2023-39914.txt
- https://nlnetlabs.nl/downloads/bcder/CVE-2023-39914.txt
Get alerted when CVE-2023-39914 or the next vulnerability affects your stack