What’s Vulnerable › Vulnerabilities
CVE-2023-39915: Crashes on parsing certain invalid RPKI objects
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-13 · updated 2026-06-17
- Weakness: CWE-232
Description
NLnet Labs' Routinator up to and including version 0.12.1 may crash when trying to parse certain malformed RPKI objects. This is due to insufficient input checking in the bcder library covered by CVE-2023-39914.
Affected products
- NLnet Labs Routinator: before 0.12.2 — fixed in 0.12.2
How to fix
Upgrade to a fixed version: NLnet Labs Routinator 0.12.2. Check the vendor advisory for mitigations.
References
- https://nlnetlabs.nl/downloads/routinator/CVE-2023-39915.txt
- https://nlnetlabs.nl/downloads/routinator/CVE-2023-39915.txt
Get alerted when CVE-2023-39915 or the next vulnerability affects your stack