What’s Vulnerable › Vulnerabilities
CVE-2023-3992: PostX - Gutenberg Post Grid Blocks < 3.0.6 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-30 · updated 2026-06-17
Description
The PostX WordPress plugin before 3.0.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- WPXPO PostX: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: WPXPO PostX 3.0.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c43b669f-0377-4402-833c-817b75001888
- https://wpscan.com/vulnerability/c43b669f-0377-4402-833c-817b75001888
Get alerted when CVE-2023-3992 or the next vulnerability affects your stack