What’s Vulnerable › Vulnerabilities
CVE-2023-39945: Malformed serialized data in a data submessage leads to unhandled exception
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-11 · updated 2026-06-17
- Weakness: CWE-248
Description
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.11.0, 2.10.2, 2.9.2, and 2.6.5, a data submessage sent to PDP port raises unhandled `BadParamException` in fastcdr, which in turn crashes fastdds. Versions 2.11.0, 2.10.2, 2.9.2, and 2.6.5 contain a patch for this issue.
Affected products
- Debian Linux: 11.0, 12.0
- eProsima Fast-DDS: from 2.6.0 before 2.6.5; from 2.9.0 before 2.9.2; from 2.10.0 before 2.10.2 — fixed in 2.10.2, 2.6.5, 2.9.2
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.10.2, 2.6.5, 2.9.2. Check the vendor advisory for mitigations.
References
- https://bombshell.gtisc.gatech.edu/ddsfuzz/pcap/fastdds-exception-20230509-02.pcap
- https://github.com/eProsima/Fast-CDR/blob/v1.0.26/src/cpp/Cdr.cpp#L72-L79
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-2rq6-8j7x-frr9
- https://www.debian.org/security/2023/dsa-5481
- https://bombshell.gtisc.gatech.edu/ddsfuzz/pcap/fastdds-exception-20230509-02.pcap
- https://github.com/eProsima/Fast-CDR/blob/v1.0.26/src/cpp/Cdr.cpp#L72-L79
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-2rq6-8j7x-frr9
- https://www.debian.org/security/2023/dsa-5481
Get alerted when CVE-2023-39945 or the next vulnerability affects your stack