What’s Vulnerable › Vulnerabilities
CVE-2023-39946: Heap overflow in push_back_helper due to a CDR message
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-11 · updated 2026-06-17
- Weakness: CWE-122
Description
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.11.1, 2.10.2, 2.9.2, and 2.6.6, heap can be overflowed by providing a PID_PROPERTY_LIST parameter that contains a CDR string with length larger than the size of actual content. In `eprosima::fastdds::dds::ParameterPropertyList_t::push_back_helper`, `memcpy` is called to first copy the octet'ized length and then to copy the data into `properties_.data`. At the second memcpy, both `data` and `size` can be controlled by anyone that sends the CDR string to the discovery multicast port. This can remotely crash any Fast-DDS process. Versions 2.11.1, 2.10.2, 2.9.2, and 2.6.6 contain a patch for this issue.
Affected products
- Debian Linux: 11.0, 12.0
- eProsima Fast-DDS: from 2.6.0 before 2.6.6; from 2.9.0 before 2.9.2; from 2.10.0 before 2.10.2; 2.11.0 — fixed in 2.10.2, 2.6.6, 2.9.2
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.10.2, 2.6.6, 2.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/eProsima/Fast-DDS/commit/349227005827e8a67a0406b823138b5068cc47dc
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-j297-rg6j-m7hx
- https://www.debian.org/security/2023/dsa-5481
- https://github.com/eProsima/Fast-DDS/commit/349227005827e8a67a0406b823138b5068cc47dc
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-j297-rg6j-m7hx
- https://www.debian.org/security/2023/dsa-5481
Get alerted when CVE-2023-39946 or the next vulnerability affects your stack