What’s Vulnerable › Vulnerabilities
CVE-2023-39949: Improper validation of sequence numbers leading to remotely reachable assertion failure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-11 · updated 2026-06-17
- Weakness: CWE-617
Description
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.
Affected products
- Debian Linux: 11.0, 12.0
- eProsima Fast-DDS: from 2.6.0 before 2.6.5; 2.9.0 — fixed in 2.6.5
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/eProsima/Fast-DDS/blob/v2.9.0/src/cpp/rtps/messages/MessageReceiver.cpp#L1059
- https://github.com/eProsima/Fast-DDS/issues/3236
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-3jv9-j9x3-95cg
- https://www.debian.org/security/2023/dsa-5481
- https://github.com/eProsima/Fast-DDS/blob/v2.9.0/src/cpp/rtps/messages/MessageReceiver.cpp#L1059
- https://github.com/eProsima/Fast-DDS/issues/3236
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-3jv9-j9x3-95cg
- https://www.debian.org/security/2023/dsa-5481
Get alerted when CVE-2023-39949 or the next vulnerability affects your stack