What’s Vulnerable › Vulnerabilities
CVE-2023-39958: Missing brute force protection on password reset token OAuth2 API controller
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-10 · updated 2026-06-17
- Weakness: CWE-307
Description
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. Starting in version 22.0.0 and prior to versions 22.2.10.13, 23.0.12.8, 24.0.12.5, 25.0.9, 26.0.4, and 27.0.1, missing protection allows an attacker to brute force the client secrets of configured OAuth2 clients. Nextcloud Server versions 25.0.9, 26.0.4, and 27.0.1 and Nextcloud Enterprise Server versions 22.2.10.13, 23.0.12.8, 24.0.12.5, 25.0.9, 26.0.4, and 27.0.1 contain a patch for this issue. No known workarounds are available.
Affected products
- Nextcloud Server: from 22.0.0 before 22.2.10.14; from 23.0.0 before 23.0.12.9; from 24.0.0 before 24.0.12.5; from 25.0.0 before 25.0.9; from 26.0.0 before 26.0.4; 27.0.0 — fixed in 22.2.10.14, 23.0.12.9, 24.0.12.5, 25.0.9, 26.0.4
How to fix
Upgrade to a fixed version: Nextcloud Server 22.2.10.14, 23.0.12.9, 24.0.12.5, 25.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vv27-g2hq-v48h
- https://github.com/nextcloud/server/pull/38773
- https://hackerone.com/reports/1258448
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vv27-g2hq-v48h
- https://github.com/nextcloud/server/pull/38773
- https://hackerone.com/reports/1258448
Get alerted when CVE-2023-39958 or the next vulnerability affects your stack