What’s Vulnerable › Vulnerabilities
CVE-2023-39960: Nextcloud Server has improper restriction of excessive authentication attempts on WebDAV endpoint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-13 · updated 2026-06-17
- Weakness: CWE-307
Description
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. In Nextcloud Server starting with 25.0.0 and prior to 25.09 and 26.04; as well as Nextcloud Enterprise Server starting with 22.0.0 and prior to 22.2.10.14, 23.0.12.9, 24.0.12.5, 25.0.9, and 26.0.4; missing protection allows an attacker to brute force passwords on the WebDAV API. Nextcloud Server 25.0.9 and 26.0.4 and Nextcloud Enterprise Server 22.2.10.14, 23.0.12.9, 24.0.12.5, 25.0.9, and 26.0.4 contain patches for this issue. No known workarounds are available.
Affected products
- Nextcloud Server: from 22.0.0 before 22.2.10.14; from 23.0.0 before 23.0.12.9; from 24.0.0 before 24.0.12.5; from 25.0.0 before 25.0.9; from 26.0.0 before 26.0.4 — fixed in 22.2.10.14, 23.0.12.9, 24.0.12.5, 25.0.9, 26.0.4
How to fix
Upgrade to a fixed version: Nextcloud Server 22.2.10.14, 23.0.12.9, 24.0.12.5, 25.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-2hrc-5fgp-c9c9
- https://github.com/nextcloud/server/pull/38046
- https://hackerone.com/reports/1924212
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-2hrc-5fgp-c9c9
- https://github.com/nextcloud/server/pull/38046
- https://hackerone.com/reports/1924212
Get alerted when CVE-2023-39960 or the next vulnerability affects your stack