What’s Vulnerable › Vulnerabilities
CVE-2023-39962: Users can delete external storage mount points
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-10 · updated 2026-06-17
- Weakness: CWE-284
Description
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. Starting in version 19.0.0 and prior to versions 19.0.13.10, 20.0.14.15, 21.0.9.13, 22.2.10.14, 23.0.12.8, 24.0.12.5, 25.0.9, 26.0.4, and 27.0.1, a malicious user could delete any personal or global external storage, making them inaccessible for everyone else as well. Nextcloud server versions 25.0.9, 26.0.4, and 27.0.1 and Nextcloud Enterprise Server versions 19.0.13.10, 20.0.14.15, 21.0.9.13, 22.2.10.14, 23.0.12.9, 24.0.12.5, 25.0.9, 26.0.4, and 27.0.1 contain a patch for this issue. As a workaround, disable app files_external. This also makes the external storage inaccessible but retains the configurations until a patched version has been deployed.
Affected products
- Nextcloud Server: from 19.0.0 before 19.0.13.10; from 20.0.0 before 20.0.14.15; from 21.0.0 before 21.0.9.13; from 22.0.0 before 22.2.10.14; from 23.0.0 before 23.0.12.9; from 24.0.0 before 24.0.12.5 — fixed in 19.0.13.10, 20.0.14.15, 21.0.9.13, 22.2.10.14, 23.0.12.9, 24.0.12.5
How to fix
Upgrade to a fixed version: Nextcloud Server 19.0.13.10, 20.0.14.15, 21.0.9.13, 22.2.10.14. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xwxx-2752-w3xm
- https://github.com/nextcloud/server/pull/39323
- https://hackerone.com/reports/2047168
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xwxx-2752-w3xm
- https://github.com/nextcloud/server/pull/39323
- https://hackerone.com/reports/2047168
Get alerted when CVE-2023-39962 or the next vulnerability affects your stack