What’s Vulnerable › Vulnerabilities
CVE-2023-39975
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-415
Description
kdc/do_tgs_req.c in MIT Kerberos 5 (aka krb5) 1.21 before 1.21.2 has a double free that is reachable if an authenticated user can trigger an authorization-data handling failure. Incorrect data is copied from one ticket to another.
Affected products
- MIT Kerberos 5: from 1.21 before 1.21.2 — fixed in 1.21.2
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.21.2. Check the vendor advisory for mitigations.
References
- https://github.com/krb5/krb5/commit/88a1701b423c13991a8064feeb26952d3641d840
- https://github.com/krb5/krb5/compare/krb5-1.21.1-final...krb5-1.21.2-final
- https://security.netapp.com/advisory/ntap-20230915-0014/
- https://security.netapp.com/advisory/ntap-20240201-0005/
- https://security.netapp.com/advisory/ntap-20240201-0008/
- https://web.mit.edu/kerberos/www/advisories/
- https://github.com/krb5/krb5/commit/88a1701b423c13991a8064feeb26952d3641d840
- https://github.com/krb5/krb5/compare/krb5-1.21.1-final...krb5-1.21.2-final
- https://security.netapp.com/advisory/ntap-20230915-0014/
- https://security.netapp.com/advisory/ntap-20240201-0005/
- https://security.netapp.com/advisory/ntap-20240201-0008/
- https://web.mit.edu/kerberos/www/advisories/
Get alerted when CVE-2023-39975 or the next vulnerability affects your stack