What’s Vulnerable › Vulnerabilities
CVE-2023-39978
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-08 · updated 2026-06-17
- Weakness: CWE-401
Description
ImageMagick before 6.9.12-91 allows attackers to cause a denial of service (memory consumption) in Magick::Draw.
Affected products
- Fedoraproject Fedora: 37
- ImageMagick: before 6.9.12-91 — fixed in 6.9.12-91
How to fix
Upgrade to a fixed version: ImageMagick 6.9.12-91. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick6/commit/c90e79b3b22fec309cab55af2ee606f71b027b12
- https://github.com/ImageMagick/ImageMagick6/compare/6.9.12-90...6.9.12-91
- https://github.com/rmagick/rmagick/pull/1406/files
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4UFQJCYJ23HWHNDOVKBHZQ7HCXXL6MM3/
- https://github.com/ImageMagick/ImageMagick6/commit/c90e79b3b22fec309cab55af2ee606f71b027b12
- https://github.com/ImageMagick/ImageMagick6/compare/6.9.12-90...6.9.12-91
- https://github.com/rmagick/rmagick/pull/1406/files
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4UFQJCYJ23HWHNDOVKBHZQ7HCXXL6MM3/
Get alerted when CVE-2023-39978 or the next vulnerability affects your stack