What’s Vulnerable › Vulnerabilities
CVE-2023-39979: MXsecurity Authentication Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-02 · updated 2026-06-17
- Weakness: CWE-334
Description
There is a vulnerability in MXsecurity versions prior to 1.0.1 that can be exploited to bypass authentication. A remote attacker might access the system if the web service authenticator has insufficient random values.
Affected products
- Moxa MXsecurity Series: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: Moxa MXsecurity Series 1.1.0. Check the vendor advisory for mitigations.
References
- https://www.moxa.com/en/support/product-support/security-advisory/mpsa-230403-mxsecurity-series-multiple-vulnerabilities
- https://www.moxa.com/en/support/product-support/security-advisory/mpsa-230403-mxsecurity-series-multiple-vulnerabilities
Get alerted when CVE-2023-39979 or the next vulnerability affects your stack