What’s Vulnerable › Vulnerabilities
CVE-2023-40000: WordPress LiteSpeed Cache plugin <= 5.7 - Unauthenticated Site Wide Stored XSS vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 54.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LiteSpeed Technologies LiteSpeed Cache allows Stored XSS.This issue affects LiteSpeed Cache: from n/a through 5.7.
Affected products
- LiteSpeed Technologies LiteSpeed Cache: before 5.7.0.1 — fixed in 5.7.0.1
How to fix
Upgrade to a fixed version: LiteSpeed Technologies LiteSpeed Cache 5.7.0.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/litespeed-cache/wordpress-litespeed-cache-plugin-5-7-unauthenticated-site-wide-stored-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/litespeed-cache/wordpress-litespeed-cache-plugin-5-7-unauthenticated-site-wide-stored-xss-vulnerability?_s_id=cve
- https://github.com/rxerium/CVE-2023-40000
Get alerted when CVE-2023-40000 or the next vulnerability affects your stack