What’s Vulnerable › Vulnerabilities

CVE-2023-4002: Insertion of Sensitive Information Into Sent Data in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 14.1 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. It was possible for EE-licensed users to link any security policy project by its ID to projects or groups the user has access to, potentially revealing the security projects's configured security policies.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.0.8, 16.1.3, 16.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-4002 or the next vulnerability affects your stack