What’s Vulnerable › Vulnerabilities
CVE-2023-40020: Improper Authentication in PrivateUploader
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-287
Description
PrivateUploader is an open source image hosting server written in Vue and TypeScript. In affected versions `app/routes/v3/admin.controller.ts` did not correctly verify whether the user was an administrator (High Level) or moderator (Low Level) causing the request to continue processing. The response would be a 403 with ADMIN_ONLY, however, next() would call leading to any updates/changes in the route to process. This issue has been addressed in version 3.2.49. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- PrivateUploader: before 3.2.49 — fixed in 3.2.49
How to fix
Upgrade to a fixed version: PrivateUploader 3.2.49. Check the vendor advisory for mitigations.
References
- https://github.com/PrivateUploader/PrivateUploader/commit/869657d61e3c7a518177106fe63ea483082b0d3e
- https://github.com/PrivateUploader/PrivateUploader/security/advisories/GHSA-vhrw-2472-rrjx
- https://github.com/PrivateUploader/PrivateUploader/commit/869657d61e3c7a518177106fe63ea483082b0d3e
- https://github.com/PrivateUploader/PrivateUploader/security/advisories/GHSA-vhrw-2472-rrjx
Get alerted when CVE-2023-40020 or the next vulnerability affects your stack